EZ Data Logger

EZ Data Logger 是一個簡易型的數據採集軟體，可以讓使用者可以很快速、簡單的架設一個數據採集系統，省去撰寫程式的麻煩。

下載:

CD:\napdas\Driver\EZ_Data_Logger 　或是
http://ftp.icpdas.com/pub/cd/8000cd/napdos/driver/ez_data_logger/


Features

主要功能

  • 支援 DCON, Modbus RTU, Modbus Ascii, Modbus TCP 等通訊協定

  • 支援多個 COM Ports 與 TCP/IP 連線

  • 支援虛擬通道的定義
    使用者可以利用各通道的Tag名稱來建立運算式，虛擬通道會自動算出結果。比如: VC1 = (AI_2 + AI_3) / 2

  • 支援邏輯控制 (VB Script)
    使用者可以編輯Script，利用通道的Tag名稱來設定輸出值或是計算虛擬通道的數值 。比如: If AI_0 > 50 Then DO_0 = 1

  • 靈活的模組設定
    每一個I/O點都可以批次修改與命名，讓使用者容易辨識，也可以個別設定趨勢圖的顏色。
  • 靈活的群組設定
    IO通道可以任意加入群組。
  • 即時趨勢圖 (可放大縮小)
    趨勢圖可以紀錄超過一天的資料。

  • Layout嵌入背景圖
    使用者可以嵌入工廠平面圖，拖曳IO點到對應位置來顯示。使用者也可以選擇各種不同的Layout物件，例如: 指針型錶頭、刻度型錶頭、數字型LED......

  • 使用Access資料庫格式
    內建資料庫開啟程式，並且可以將舊資料製表、繪圖、與匯出成Excel或CVS檔案格式。

  • 報表列印
    即時的趨勢圖、資料庫製表、資料庫繪圖都可以列印出來。

  • 警示燈與警示聲
    每一個類比輸入通道都可以設定 上/下限的警示值，當採集到的數值超出或低於警示範圍，警示燈會亮起，並且有警示聲提醒，直到使用者將警示燈關閉。

  • 可以直接搜尋DCON與M7000系列的模組
    DCON系列包含7000, 87K, 8000等, Modbus系列包含M7000可以自動搜尋加入。

  • 數值轉換
    設定Gain(斜率)及Offset (補償值)後，可以直接將類比數值的單位從原先的伏特或安培轉換成另一個實際的物理量，例如代表旋轉速度的 rpm 或代表重量的 kg。

  • 不需撰寫程式
    所有操作使用滑鼠和輸入數值即可完成。


Module Supported

支援的模組

  • DCON modules (I-7000, I-87K, I-8000 series)
    I-7000 Remote I/O Module
    I-8000 Main Control Unit
    8K and 87K I/O Modules
  • Modbus/TCP
    I-8000E-MTCP
    I-8000E-MTCP Support modules
    ET-6000
    ISaGRAF controllers ( I-8417/8817/8437/8837, I-7188EG, I-7188XG, Wincon-8x37 )
    7188E-MTCP
  • Modbus/RTU
    M-7000 series
  • Devices with Modbus RTU, Modbus Ascii, Modbus TCP protocols


Limitation

軟體性質

  • 每個群組最多可以設定32個IO通道
  • 必須使用至少一個ICPDAS的Modbus裝置來啟動所有的Modbus驅動(請參閱 Q2 )


Quick Start

快速上手

  • Step 5.1 系統設定
  • Step 5.2 群組設定
  • Step 5.3 開始執行(或是進行模擬)
    • Step 5.3.1 量測計
    • Step 5.3.2 趨勢圖
    • Step 5.3.3 對應位置
  • Step 5.4 開啟資料庫


Configure System

系統設定

顯示方式:

  • 數列模式:使用筆數序列來記錄， 最小取樣時間 0.01 秒。
  • 時間模式:使用時間序列來記錄， 最小取樣時間 1 秒。

    X軸的座標顯示方式不同

    數列模式
    時間模式

取樣時間(秒):
掃描數值、更新資料庫、顯示數值的時間間隔。

可視範圍(分):
趨勢圖X軸的可視範圍。

趨勢圖記錄筆數:
每一條曲線所能紀錄的點數。

資料格式:
數值顯示的資料格式。

程式啟動時自動開始紀錄:
勾選此項設定可以在程式執行時自動開始紀錄。你可以在開始=>程式集=>啟動 的地方建立程式捷徑，當電腦電源啟動進入Windows時，即可自動記錄。

儲存間隔(秒):
儲存到資料庫的時間間隔，必須是取樣時間的倍數。

紀錄長度(小時):
當紀錄長度的時間期滿，EZ Data Logger 會重新建立新的資料庫開始紀錄。

資料庫檔名:
資料庫檔案名稱會以Datayyyymmdd_hh.mdb 來自動命名。(yyyy:西元年 mm:月 dd:日 hh:小時)


2.Group setup

群組設定

Step 5.2.1 安裝驅動程式
Step 5.2.2 安裝裝置
Step 5.2.3 修改通道設定予新增到群組
Step 5.2.4 工作群組屬性


2.1 Install driver

安裝驅動程式

驅動程式列表
你可以從這邊安裝 DCON / Modbus serial / Modbus TCP 驅動程式
安裝驅動程式
修改驅動程式
刪除指定驅動程式(如果有裝置正在使用該驅動程式時，將無法刪除)


安裝驅動程式 DCON

驅動類型: DCON

Time Out(ms): 200 (預設值)(可修改)

COM Port: 選擇連線的序列埠(不可變更)。 你無法在同一個序列埠上安裝其他類型的驅動程式。

BaudRate: 115200 (預設值)(可修改)

Checksum: Disable (預設值)(可修改)

安裝: 安裝驅動程式，安裝以後只有可修改的選項可以變更設定

修改: 變更修改的設定。

搜尋: 可以搜尋DCON的模組並自動新增。

新增裝置: 使用者自訂的方式新增DCON模組。 See 5.2.2 新增裝置 DCON.

裝置列表: 列出正在使用這個驅動程式的裝置。

>Search: To search for M7000 modules and add them after stop searching.


安裝驅動程式 Modbus Serial

驅動類型: Modbus Serial

Time Out(ms): 400 (預設值)(可修改)

Mode: RTU or ASCII

COM Port:選擇連線的序列埠(不可變更)。 你無法在同一個序列埠上安裝其他類型的驅動程式。

BaudRate: 115200 (預設值)(可修改)

Data Bits: 8 (預設值)(可修改)

Parity: 0-NoneParity (預設值)(可修改)

Stop Bit: 1 (預設值)(可修改)

修改: 變更修改的設定。

搜尋: 可以搜尋M-7000的模組並自動新增。

新增裝置: 使用者自訂的方式新增Modbus Serial模組。 See 5.2.2 新增裝置 Modbus Serial 。

裝置列表: 列出正在使用這個驅動程式的裝置。

lass=a12b


安裝驅動程式 Modbus TCP

驅動類型: Modbus TCP

Time Out(ms): 1500 (預設值)(可修改)

IP: IP Address.

Port: TCP/IP連線埠。

修改: 變更修改的設定。

搜尋: 不支援。

新增裝置: 使用者自訂的方式新增Modbus TCP模組。 See 5.2.2 新增裝置 Modbus TCP。

裝置列表: 列出正在使用這個驅動程式的裝置。

修改: 變更修改的設定。

搜尋: 不支援。

新增裝置: 使用者自訂的方式新增Modbus TCP模組。 See 5.2.2 新增裝置 Modbus TCP l 。

裝置列表: 列出正在使用這個驅動程式的裝置。


2.2 Add Device

新增裝置

裝置列表
你可以從這邊新增裝置DCON / Modbus serial / Modbus TCP
新增裝置
修改裝置設定
刪除指定裝置


新增裝置 DCON

選擇 "DCON Device" 然後按下

選擇使用的驅動程式 => 輸入各項參數 =>按下

選項的差異:

 | 7K | 87K on 87K4/87K8 | 87K on 8431/8831 | 8K
Slot | X | X | 0~7 | 0~7

Module: 你可以從這裡選一個DCON裝置，參數將會自動填入。

Nickname: 你可以自訂裝置的名稱方便辨識。

Address: 裝置在485網路上的ID數值。

Slot: Slot number (for 8000 MCU).

AINum: 類比輸入的通道數。

AONum: 類比輸出的通道數。

DINum: 數位輸入的通道數。

DONum: 數位輸出的通道數。

Description: 會在裝置狀態區域顯示成提示文字。

Nickname與Description可以稍候修改。


新增裝置 Modbus Serial

選擇 "Modbus/RTU" 然後按下

選擇使用的驅動程式 => 輸入各項參數 =>按下

Slave ID: The modbus ID number.

Module: 你可以選擇一個 ICPDAS M-7000 系列的模組。

Nickname: 你可以自訂裝置的名稱方便辨識。

Description: 會在裝置狀態區域顯示成提示文字。

0xxxx Coils (DO): 從起始位址到結束未址。

1xxxx Discrete Input (DI): 從起始位址到結束未址。

3xxxx Input Registers (AI): 從起始位址到結束未址。

4xxxx Holding Registers (AO): 從起始位址到結束未址。

Address format: Dec 為十進位、Hex 為十六進位。

Base Address: 0 or 1.

Nickname與Description可以稍候修改。


新增裝置 Modbus TCP

選擇 "Modbus/TCP" 然後按下

選擇使用的驅動程式 => 輸入各項參數 =>按下

Nickname: 你可以自訂裝置的名稱方便辨識。

Description: 會在裝置狀態區域顯示成提示文字。

Slave ID: The modbus ID number.

0xxxx Coils (DO): 從起始位址到結束未址。

1xxxx Discrete Input (DI): 從起始位址到結束未址。

3xxxx Input Registers (AI): 從起始位址到結束未址。

4xxxx Holding Registers (AO): 從起始位址到結束未址。

Address format: Dec 為十進位、Hex 為十六進位。

Base Address: 0 或 1。

Nickname與Description可以稍候修改。


通道修改與新增到群組

所有通道可以任意加到指定的群組。

按下 [image] 將選擇的通道加到群組。.

按下 [image] 可以修改通道的nickname, gain, offset, high/low alarm, or description 等設定。

修改完設定值後，請按下"Modify"儲存。

Nickname: 你可以指定nickname以方便辨識。

Tag: Tag name 可以用在Visual Channel或是Control logic. (請注意 : Tag name 必須使用開頭為a~z的英文字母,第一個字母不可以使用數字)

Description: 可以在顯示的物件上顯示提示文字。

Gain and Offset: 設定 Gain 和 Offset 可以轉換成你需要的單位。

Caculate: 按下 [image] 可以利用point1和point2計算出 gain 和 offset。請參閱 Q&A.

High/Low Alarm: 每一個類比輸入通道都可以設定其高或是低的警戒值，一但數值高於高警戒值或是低於低警戒值時，警示燈會亮起並會播放警示聲。警示狀態會持續到使用者將警示燈關閉(位於量測計裡面)。

Init Value: Visual channel的初始值 。

Operation: Visual channel 的運算式。

Display Mode: 你可以選擇各通道的顯示物件(Text Box / Angular Gauge / Linear Gauge / Perecent / Number LED / Toggle)。

Style List: 你可以選擇各類物件的不同樣式。


Workgroup Property

工作群組屬性

你可以從這裡新增或是刪除工作群組，每一個工作群組可以加入32個通道。

: 增加一個工作群組

: 刪除指定的工作群組

: 設定工作群組名稱與自動開啟的畫面

: 清除所有的通道

: 回到主畫面

工作群組屬性設定:

工作群組名稱: 你可以設定一個方便辨識的工作群組名稱。

隨啟動開啟畫面: 勾選時，可以隨程式啟動時自動開啟畫面。


Workgroup Property

專案檔操作

使用中的專案包括一個設定檔,一個Script檔案與圖片目錄， 你可以作下列這些專案的操作。

新增專案: 開啟一個新的專案。

開啟專案: 開啟其他專案檔。

另存專案: 將目前的專案另存。


Workgroup Property

保全功能

如果您不希望其他使用者變更程式設定，您可以設定密碼來取消系統設定與群組設定的按鈕功能。

Set Password:

Password protection: Click logout to disable these buttons. Every time to excute EZ Data Logger will disable these buttons also.

Login: Click login to enable these two buttons. Set password empty to disable password protection.


Screen

開始執行

開始執行。開始顯示數值與紀錄。

停止執行。

模擬數值並開始紀錄。

停止模擬。

暫停動態顯示所有趨勢圖。

繼續動態顯示趨勢圖。

暫停記錄到資料庫。

記錄到資料庫。


Gauge

量測計畫面

點選主畫面的"量測計"來顯示量測計畫面。

範圍 (AI最大值 / AI最小值): 變更Gauge的顯示範圍。

<<: 切換到前一個工作群組。

>>: 切換到下一個工作群組。

趨勢圖: 切換到趨勢圖顯示。

平面配置圖: 切換到平面配置圖顯示。

隱藏: 隱藏畫面並顯示主畫面。

AO

切換通道按鈕: 假如群組有超過8個類比輸入通道的話，可以點選按鈕切換顯示的通道。

警示燈: 當數值超過警戒值時，警示燈會亮起，並保持亮燈的狀態。

關閉警示燈: 點一下以關閉警示燈。如果有警示燈亮起， EZ Data Logger 會播放警示音效。


Trend

趨勢圖顯示

點選主畫面的"趨勢圖"來開啟趨勢圖顯示。

顯示(暫停/繼續): 暫停/繼續 趨勢圖。

列印: 列印趨勢圖。

顯示範圍: 設定Y最大最小值,X軸範圍(分).

背景顏色: 設定趨勢圖背景顏色。

全選: 顯示所有趨勢圖線條。

全不選:隱藏所有趨勢圖線條。

<<: 切換到前一個工作群組。

>>: 切換到下一個工作群組。

量測計: 切換到量測計顯示。

平面配置圖: 切換到平面配置圖顯示。

隱藏:隱藏畫面並顯示主畫面。

滑動按鈕: 可以放大縮小顯示範圍。

Value: 點選Value的格子可以開啟設定AO/DO 的設定視窗, 也可以將Counter 歸零。

Track: 點選Track的格子來切換顯示到不同的Track

Color: Click the color grid to change the trend line color( You can not change the color when start logging ).

Check box: =>show the trend line, [image] =>hide the trend line.

Cursor Mode: Set display pause to change trend to cursor mode. Then you can click the trend to show the before values .


Trend

平面配置圖

點選主畫面的"平面配置圖"來開啟平面配置圖顯示。

圖片(背景圖): 設定配景圖片，支援圖片格式 *.jpg, *.bmp。

圖片(取消背景圖): 清除背景圖。

重設位置: 重設所有物件位置。

字體顏色: 設定標籤顏色。

<<: 切換到前一個工作群組。

>>: 切換到下一個工作群組。

量測計: 切換到量測計顯示。

平面配置圖: 切換到平面配置圖顯示。

隱藏:隱藏畫面並顯示主畫面。

滑鼠右鍵功能表:

手動控制 : 啟用滑鼠控制 ( 滑鼠控制輸出值 )。

自動輸出 : 取消滑鼠控制 ( control logic 會自動設定輸出值 )。

屬性 : 顯示通道屬性。

設定小數位數 : 設定顯示的小數位數。

設定單位 : 設定顯示單位。

顯示數值設定範例: (數值 = 123.456)

小數位數 | 單位 | 顯示
0 | ℃ | 123 ℃
1 | ℉ | 123.5 ℉
2 | kg | 123.46 kg
3 | V | 123.456 V


Trend

開啟資料庫

開啟資料庫可以將較早的資料叫出繪出趨勢圖，並且可以匯出成 Excel 或是 CSV 的檔案。

列印: 列印趨勢圖或是資料表格(最多12個通道)。

全選: 顯示趨勢圖所有的線條。

全不選: 隱藏所有趨勢圖線條。

Y軸範圍(最大值/最小值): 設定Y軸最大值最小值

X軸範圍: X軸的可視範圍(分)。

背景顏色: 設定趨勢圖背景顏色。

開啟資料庫繪圖三步驟

步驟一. 選擇資料庫: 在資料庫列表上點一下或是點 [image] 開啟其他路徑的資料庫檔案。

步驟二. 選擇一個工作群組: 點一下工作群組列表上的工作群組。

步驟三. Scroll the pointer to choose time range. Then you can click "Load Trend" to plot the trend, or click "Load Table" to load the data table.

Print the trend or the table.

Export to Excel or CSV.

Trend: Click the trend can show the cursor values on the left table.

Table: Click the check box on the left side to show/hide the row of the channel.


Visual Channel

你可以使用通道的Tag名稱來作運算，將運算結果存到Visual Channel。

設定 visual channel 數量: (最多256個通道)

設定visual channel 運算式:

1. Visual Channels 是可運算的. 你可以使用Tag name 來作運算

例如:
VC0 = (AI_1 + AI_2) / 2
VC1 = AI_3 ^ 2 * 100
VC2 = DO_0 And DO_1
VC3 = Abs(AI_6)

2.可以用的運算子

乘 *
除 /
加 +
減 -
次方 ^
邏輯運算子 Not, And, Or, Xor....

3.可以使用的基本函數

你可以在算式中使用這些VB函數
Sin(number) | 傳回引數的 sine(正弦函數)值
Cos(number) | 傳回引數值的 cosine(餘弦函數) 值。
Tan(number) | 傳回引數的「正切」(tangent)函數值。
Atn(number) | 傳回引數的「反正切」(arctangent)函數值。
Abs(number) | 傳回引數的絕對值。
Sqr(number) | 傳回引數的平方根。

4.Initial Value
  VC的起始值


控制邏輯

控制邏輯使用VB Script。你可以編輯 Script 內容來設定輸出數值或是將計算資料放到Visual Channel，使用時你可以使用各通道的 Tag 名稱來取得或是設定數值。

你可以在Control Logic裡面編輯邏輯控制, 如果你啟用邏輯控制, EZ Data Logger會自動對邏輯控制的AO/DO數值作輸出的動作,此時Layout的AO/DO的控制將無法操作,如需切換到手動, 可以選擇控制模式, 請參閱: 平面配置圖顯示滑鼠右鍵功能表

陳述式 :

可以使用的If...Then...., For...Next....的陳述式如下

If condition1 Then
  [statementblock-1]
ElseIf condition2 Then
  [statementblock-2]] ...
Else
  [statementblock-n]]
End If

變數 :

你可以在Script裡面使用這些參數

iYear : | 年
iMonth : | 月
iDay : | 日
iHour : | 時
iMinute : | 分
iWeekDay : | 每星期的第幾天 (星期日 = 1, 星期一 = 2, 星期二= 3.....星期六 = 7)
Now : | 回覆系統時間。
Timer : | 回覆從午夜12:00到此刻經過的秒數。
Msg : | 如果Msg不為空的話， 會將內容輸出到主畫面的警告視窗。

常數 :

你可以在Script裡面使用這些常數

常數 | 代表意義
Sunday | 星期日
Monday | 星期一
Tuesday | 星期二
Wednesday | 星期三
Thursday | 星期四
Friday | 星期五
Saturday | 星期六

函數 :

你可以在 Script 裡面使用這些函數

Sin(number) | 傳回引數的 sine(正弦函數)值
Cos(number) | 傳回引數值的 cosine(餘弦函數) 值。
Tan(number) | 傳回引數的「正切」(tangent)函數值。
Atn(number) | 傳回引數的「反正切」(arctangent)函數值。
Abs(number) | 傳回引數的絕對值。
Sqr(number) | 傳回引數的平方根。

範例 :

'開啟DO警報
If AI_5 > 100 Then
  DO_3 = 1
  Msg="High Alarm"
End If

'紀錄最大值
If AI_2 > VC0 Then
  VC0 = AI_2
  Msg = "AI_2 Max Value is " & VC0
End IF

'計算平均值並設定到AO_2
AO_2 = ( AI_1 + AI_2 + AI_3 ) / 3

'使用公用變數判斷星期六星期日關閉冷氣
If iWeekDay = Saturday Or iWeekDay = Sunday Then
  AirConditioning = 0
Else
   AirConditioning = 1
End If

'使用邏輯運算
DO_3 = DI_2 And DI_3

'


問題與解答

問題一:如何將類比訊號轉換成其他單位，列如 kg?

設定Gain(斜率)及Offset(補償值)可以將電壓值( V )轉換成您需要的單位量( kg )。要獲得這兩個數值請依照它們的對應關係先找出兩組數據，然後依照以下步驟來求得Gain與Offset

在通道修改的設定畫面可以自動計算 : 輸入兩點的擷取數值(AI Value)和顯示數值(Display Value)即可自動計算出Gain, Offset。

問題二 : 如何啟動Modbus驅動程式?
當您安裝Modbus驅動程式時,你必須至少連接一個ICPDAS的Modbus裝置來啟用所有的Modbus驅動程式。然後這些Modbus驅動程式即可存取其他Modbus的裝置, 例如PLC.....
下列ICPDAS模組可以用來連線啟動Modbus驅動程式。

M7000 serial modules, I-7188EX-MTCP, I-8000-MTCP, ET-6000, ISaGRAF controllers ( I-8417/8817/8437/8837, I-7188EG, I-7188XG, Wincon-8x37 )