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Industrial 2G/3G module 

I-8212W/I-8213W 

I-8212W-3GWA/I-8213W-3GWA 

 User Manual 

 
 
Warranty 

All products manufactured by ICP DAS are warranted against 
defective materials for a period of one year from the date of delivery 
to the original purchaser. 

 
Warning 

ICP DAS assumes no liability for damages consequent to the 
use of this product. ICP DAS reserves the right to change this 
manual at any time without notice. The information furnished by ICP 
DAS is believed to be accurate and reliable. However, no 
responsibility is assumed by ICP DAS for its use, or for any 
infringements of patents or other rights of third parties resulting from 
its use. 

 
Copyright 

Copyright 2011 by ICP DAS Co., Ltd. All rights reserved 
worldwide. 

 
Trademark 

The names used for identification only may be registered 
trademarks of their respective companies. 
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Chapter 1 Introduction  

 

The I-8212W/I-8213W is an industrial Quad-band GSM/GPRS module with GPS function (only 

I-8213W) that work on frequencies of 850/900/1800/1900 MHz. The I-8212W-3GWA/I-8213WA is 

an industrial Tri-band 3G module with GPS function (only I-8213W-3GWA) that work on 

frequencies of WCDMA 2100/1900/850 MHz and GSM 850/900/1800/1900 MHz. These modules 

utilize the 2G/3G network for convenient and inexpensive data transfer from remote instruments, 

meters, computers or control systems in either live data or packet data. These modules have the 

integrated TCP/IP stack so that even simple controllers with serial communications ports can be 

connected to the modem without the need for special driver implementation. With the features of 

theirs, the systems can be SMS and GPRS or 3G connection applications with our PAC series like 

iPAC-8000, WinPAC-8000, LinPAC-8000 or XP-8000. 
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Chapter 2 Hardware Specifications  

2.1.1 I-8212W/I-8213W 

  

Model: I-8212W Model: I-8213W 
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2.1.2 I-8212W/I-8213W Specifications  

 

Models I-8212W  I-8213W  

GSM/GPRS System 

GPRS/GSM 

Quad-band  
850/900/1800/1900 MHz  

GPRS Multi-slot  Class 10/8  

GPRS Mobile 

Station  
Class B  

GPRS Class 10  Max. download speed 85.6 kbps; Uplink transfer: Max 42.8 kbps 

CSD  Up to 14.4 kbps  

Compliant to GSM 

Phase 2/2+  
MT, MO, CB, Text and PDU mode 

Coding Schemes  CS 1, CS 2, CS 3, CS 4  

SMS  Text and PDU Mode  

GPS System  

Support Channels - 32 

Sensitivity - 

Tracking = up to -159 dBm (with 

external LNA) Cold start = up to 

-146 dBm (with external LNA) 

Acquisition Time - 

Hot start (Open Sky) = 2 

sec.(typical)  

Cold start (Open Sky) = 36 

sec.(typical) 

Protocol Support - NMEA 0183 version 3.01 

LED Indicators  

Power Red color 

GSM/GPRS  Yellow color 

GPS  - Green color 

Power  

Frame Ground 

Protection  
ESD, Surge, EFT, Hi-Pot  

Power 

Consumption  
Idle: 0.16 A @ 5 VDC; Data Link: 0.2 ~ 1.64 A (peak) @ 5 VDC  

Mechanical  

Casing Plastic 

Dimensions  30 mm x 85 mm x 114 mm  
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(W x L x H)  

Environment  

Operating 

Temperature  
-25 °C ~ +75 °C  

Storage 

Temperature  
-30 °C ~ +80 °C  

Humidity  5 ~ 95% RH, non-condensing  

 

Note1: The default setting of GSM/GPRS module is as following on 

I-8212W/I-8213W. 

Parameters Default value 

Baud rate 115200 bps 

Parity None 

Date bit 8 

Stop bit 1 

 

Note2: The default setting of GPS module is as following on I-8213W. 

Parameters Default value 

Baud rate 9600 bps 

Parity None 

Date bit 8 

Stop bit 1 
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2.1.3 I-8212W/I-8213W Features 

 Quad-band GSM/GPRS Modem Operating on 850/900/1800/1900 MHz 

 4 KV ESD Protection   

 Designed for GPRS and SMS Applications 

 Support TCP Server, TCP Client, UDP Client Connection stack from GPRS 

 Support Standard AT Commands 

 LED Indicators for Power, GSM and GPS(only I-8213W) Indication 

 High Reliability in Harsh Environment 

 Support 32-channels GPS and NMEA v0183 v3.01(only I-8213W) 

 PPS: 100 ms pulse output/sec for precise timekeeping and time measurement(only 

I-8213W) 

 Support XP-8000, WinPAC-8000, LinPAC-8000, ViewPAC, iPAC-8000 
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2.2.1 I-8212W-3GWA/I-8213W-3GWA 

  

Model: I-8212W-3GWA Model: I-8213W-3GWA 

 



 

I-8212/13W (3GWA) User Manual 

Publication Dec, 2011 Ver. 1.02  9 

2.2.2 I-8212W-3GWA/I-8213W-3GWA Specifications  

 

Models I-8212W-3GWA I-8213W-3GWA 

3G System 

Frequency Band UMTS : 2100/1900/850 MHz 

Data Transmission 
UMTS / HSDPA / HSUPA 

Downlink transfer: Max. 7.2Mbps; Uplink transfer: Max 5.76Mbps 

GSM/GPRS System 

Frequency Band 850/900/1800/1900 MHz  

GPRS connectivity GPRS class 12/10; GPRS station class B 

DATA GPRS Downlink transfer: Max. 85.6 kbps; Uplink transfer: Max 42.8kbps 

CSD Max. download speed 85.6 kbps; Uplink transfer: Max 42.8 kbps 

Coding Schemes CS 1, CS 2, CS 3, CS 4 

SMS System 

SMS MT, MO, CB, Text and PDU mode 

GPS System  

Support Channels - 32 

Sensitivity - 

Tracking = up to -159 dBm (with 

external LNA) Cold start = up to 

-146 dBm (with external LNA) 

Acquisition Time - 

Hot start (Open Sky) = 2 

sec.(typical)  

Cold start (Open Sky) = 36 

sec.(typical) 

Protocol Support - NMEA 0183 version 3.01 

LED Indicators  

Power Red color 

GSM/GPRS  Yellow color 

GPS  - Green color 

Power  

Frame Ground 

Protection  
ESD, Surge, EFT, Hi-Pot  

Power 

Consumption  
Idle: 0.16 A @ 5 VDC; Data Link: 0.2 ~ 1.64 A (peak) @ 5 VDC  

Mechanical  

Casing Plastic 

Dimensions  30 mm x 85 mm x 114 mm  
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(W x L x H)  

Environment  

Operating 

Temperature  
-25 °C ~ +75 °C  

Storage 

Temperature  
-30 °C ~ +80 °C  

Humidity  5 ~ 95% RH, non-condensing  

 

Note1: The default setting of the module is as following on 

I-8212W-3GWA/I-8213W-3GWA. 

Parameters Default value 

Baud rate 115200 bps 

Parity None 

Date bit 8 

Stop bit 1 

 

Note2: The default setting of GPS module is as following on 

I-8213W-3GWA. 

Parameters Default value 

Baud rate 9600 bps 

Parity None 

Date bit 8 

Stop bit 1 
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2.2.3 I-8212W-3GWA/I-8213W-3GWA Features 

 Supports Tri-band UMTS 2100/1900/850 MHz and  Quad-band GSM 

850/900/1800/1900 MHz 

 4 KV ESD Protection 

 Designed for WCDMA, GPRS and SMS Applications 

 Supports TCP Server, TCP Client, UDP Client Connection stack from 3G or GPRS 

 Support Standard AT Commands 

 LED Indicators for Power, GSM and GPS(only I-8213W-3GWA) Indication 

 High Reliability in Harsh Environment 

 Support 32-channels GPS and NMEA v0183 v3.01(only I-8213W-3GWA) 

 PPS: 100 ms pulse output/sec for precise timekeeping and time measurement(only 

I-8213W-3GWA) 

 Support XP-8000, WinPAC-8000, LinPAC-8000, ViewPAC, iPAC-8000 
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Chapter 3 Application architecture 

 Application 1  

 

 

 Application 2 
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Chapter 4 Hardware Appearance 

4.1 Pin Assignments 

 I-8212W 

 

 

 I-8213W 
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 I-8213W-3GWA 

 

 

 I-8213W-3GWA 
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4.2 Hardware Dimensions 

 I-8212W / I-8212W-3GWA 
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 I-8213W / I-8213W-3GWA 
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4.3 LED indicators 

 

 

There are three LED indicators to help users to judge the various conditions. The 

description is as following： 

 PWR(Red)：The PWR LED can indicate the status of Power module. 

Power normal Power fail 

Always on Always off 

 

 GSM/GPRS (Yellow)：The modem LED can indicate the status of GSM module for 

I-8212W/I-8213W. 

Modem normal Modem fail 

Blanking (3 sec) 
Off 
 or 

Blanking (not 3 sec) 

 

 3G (Yellow) ： The modem LED can indicate the status of GSM module for 

I-8212W-3GWA/I-8213W-3GWA. 

Modem normal Modem fail 

Blanking (0.8 sec) 
OFF 
 or 
ON 
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 GPS (Green)：The GPS LED can indicate the status of GPS module.(I-8213W / 

I-8213W-3GWA only) 

GPS Fail Search GPS  Receive GPS data 

Always off  Always on Blanking (1 sec) 
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Chapter 5 Hardware Installation 

5.1 SIM card Installation 

 

 

5.2 Antenna Installation 
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5.3 Install I-8212W/ I-8213W / I-8212-3GWA / I-8213-3GWA module 

5.3.1 XP-8000 (Windows Embedded Standard 2009) 

 

 Install module. 

1. Install the module on the XP-8000. 

2. Rotate the Rotary Switch as “2”. To disable EWF (ENHANCED WRITE 

FILTER). 

 

 

3. Reboot your XP-8000 

4. After reboot, execute the “Multi-Port IO module Register Wizard”.  

 4.1 Open Multi-Port IO Module Register Wizard,  

  Start => ICPDAS => Multi-Port IO Module Register Wizard 
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4.2 Register the module and select “Exit” 

    

 

 4.3 Select “OK” and reboot. 
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 4.4 After reboot, XP-8000 will install ports of the module. 

 

 

5 After finishing, rotate the Rotary Switch as “0” to enable EWF. 
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 Uninstall module 

1. Rotate the Rotary Switch as “2” to disable EWF. 

 

 

2. Reboot your XP-8000 

3. After reboot, ensure the module is installed on XP-8000 and execute the 

“Multi-Port IO module Register Wizard”.  

 3.1 Open Multi-Port IO Module Register Wizard,  

  Start => ICPDAS => Multi-Port IO Module Register Wizard 
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 3.2 Remove module and select “Exit” 

   

 

 3.3 Select “OK” and reboot. 
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 3.4 After reboot, XP-8000 will remove ports of the module. 

 

 

4 After finishing, rotate the Rotary Switch as “0”. To enable EWF. 
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 The slot corresponds to com port number of I-8212W or I-8212W-3GWA 

 

 

 

 

 

 

 The slot corresponds to com port number of I-8213W or I-8213W-3GWA 
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5.3.2 WinPAC-8000 (WinCE 5.0 Based) 

 

 Install the module 

1. Install the module on the WinPAC-8000 

2. Reboot your WinPAC-8000 

3. After reboot, execute the “WinPAC Utility”.  

 3.1 Select the “USE COMx” and then click the “Set” button. 
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 3.2 Save and Reboot parameters 

 

 

 

4. After reboot, execute the “WinPAC Utility” to check.  
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 Uninstall the module 

1. Remove the module on the WinPAC-8000 

2. Reboot your WinPAC-8000 

3. After reboot, execute the “WinPAC Utility”.  

 3.1 Click the “Set” button to remove driver. 
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3.2 Save and Reboot parameters 
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5.3.3 iPAC-8000 (miniOS7 Based) 

1. Turn on the power of your iPAC-8000 after install the module on your 

iPAC-8000. 

2. The slot corresponds to com port number below.  

 

 

 I-8212W / I-8212W-3GWA 

 

 

 

 

 

 I-8213W / I-8213-3GWA 
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5.3.4 LinPAC-8000 (Linux kernel 2.6 based) 

1. Turn on the power of your LinPAC-8000 after install the module on your 

LinPAC-8000. 

2. The slot corresponds to com port number below.  

 

 

 I-8212W / I-8212W-3GWA 

 

 

 

 

 I-8213W / I-8213W-3GWA 
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Chapter 6 GPRS connection 

6.1 XP-8000 (Windows Embedded Standard 2009) 

 Hardware requirement  

1) I-8212W/I-8213W/I-8212W-3GWA/I-8213W-3GWA 

    2) XP-8000 
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 Create a new modem connection 

Step1. Control Panel → Double-click “Phone and Modem Options” 

 

 

Step2. Set the area code for the first time → Click “OK” 
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Step3. Control Panel → Double-click “Phone and Modem Options” → Modem → Click 

“Add” 

 

 

Step4. Select “Don‟t detect my modem; I will select it from a list.” → Click “Next” 
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Step5. Select ”Standard Modem Types” → Select “Standard 19200 bps Modem”  

→ Click “Next” 

 

 

Step6. Select your COM Port to connect to the modem → Click “Next” 
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Step7. Click “Finish” to finish the install new modem. 

 

 

Step8.  Control Panel → Double-click “Phone and Modem Options” → Modem →  

Select “Standard 19200 bps Modem” → Click “Properties”  
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Step9. Control Panel → Double-click “Phone and Modem Options” → Modem →  

Select “Standard 19200 bps Modem” → Click “Properties” → Modem → 

Maximum Port Speed → 115200 

 

 

Step10. Advanced → Extra initialization commands:  

Note: GPRS‟s APN must be provided from your Telecom. CO., LTD. 

For example in Taiwan: AT+CGDCONT=1,”IP”,”INTERNET”  

For example in China: AT+CGDCONT=1,”IP”,” CMNET”  
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Step11. Diagnostics → Query Modem →Click “OK” 

Note: If user queries the modem and gets an error message, Please try again. 

  

 

Step12. Click “OK” 
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 Create a new dial-up and networking connection 

Step1. Control Panel → Network Connections → Click “Create a new connection” 

 

 

Step2. Click “Next” 
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Step3. Select “Connect to the Internet” → Click “Next” 

  

 

Step4. Select “Connect using a dial-up modem” → Click “Next” 
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Step5. ISP Name → Your GPRS‟s name → Click “Next” 

 

 

Step6. Phone Number: → Click “Next” 

Note: Phone Number must be provided from your Telecom. CO., LTD. 

For example in Taiwan: *99# 
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Step7. GPRS‟s User name and GPRS‟s Password → Click “Next” 

Note: GPRS‟s User name and GPRS‟s Password must be provided from your Telecom. 

CO., LTD. 

 

 

Step8. Click “Finish” 
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Step9. Control Panel → Network Connections → Click “Your GPRS‟s name” →  

File → Properties 

 

 

Step10. General → Select ”Standard 19200 bps Modem” → Click “Configure”  
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Step11. Maximum speed(bps) → Select ”115200” → do not select “Enable hardware 

flow control “ →  Click “OK” 
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Step12. Click “OK” 

 

 

Step13. Control Panel → Network Connections → Double-Click “Your GPRS‟s name” 
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Step14. Click “Dial” 

  

 

Step15. If you connect to internet successfully, your toolbar have new logo 

 

 

Step16. You can Double-Click the new logo → Click “Details” → Get your IP address 
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6.2 WinPAC-8000 (WinCE 5.0 Based) 

 Hardware requirement  

1) I-8212W/I-8213W/ I-8212W-3GWA/I-8213W-3GWA 

    2) WinPAC-8000 
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 Create a new modem connection 

Step1. Copy “icpdas_i-821xw_comx_v1.xx.cab” to your WinPAC → Double-Click ” 

icpdas_i-821xw_comx_v1.xx.cab” to install →  

Select “OK” 

 

Step2. Execute “WinPAC_Utility” → File → Save and Reboot 
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 Create a new dial-up and networking connection 

Step1. Control Panel → Double-Click ”Network and Dial-up Connections” 

 

 

Step2. Double-Click ”Make New Connection” 
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Step3. Key in your name for the connection → Select “Dial-Up Connection” → 

Click ”Next” 

 
 

Step4. Select “ICPDAS I-821xW COMx:” → Click “Configure…” 
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Step5. Select Baud Rate “115200”, Data Bits “8”, Parity “None”, Stop Bits “1” Note and 

FlowControl ”None”→ Click “Call Options”  

 

 

Step6. Extra Settings → Click “OK” 

Note: GPRS‟s APN must be provided from your Telecom. CO., LTD. 

For example in Taiwan: +CGDCONT=1,”IP”,”INTERNET” 

For example in China: +CGDCONT=1,”IP”,” CMNET”  
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Step7. Click “TCP/IP Settings…” 

 

 

Step8. TCP/IP Settings: Dependant on the requirement of each ISP.  
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Step9. Click “Security Settings…” 

 

 

Step10. Security Settings: Dependant on the requirement of ISP！（Below picture is the 

setting for HINET）. 
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Step11. Click “Next” 

 

 

Step12. Phone Number: → Click “Finish” 

Note: Phone Number must be provided from your Telecom. CO., LTD. 

For example in Taiwan: *99# 
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Step13. Double-Click you make new connection name 

 

 

Step14. Click “Dial Properties…” 
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Step15. Click “Dialing Patterns…” 

 

 

Step16. Key in „G‟ to all blocks → Click “OK” 
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Step17. GPRS‟s User name and GPRS‟s Password → Click “Connect” 

Note: GPRS‟s User name and GPRS‟s Password must be provided from your Telecom. 

CO., LTD. 

 

 

Step18. If you connect to internet successfully, they will show “Connected” 

 

 

Step19. Execute “WinPAC_Utility” → File → Save and Reboot 
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6.3 LinPAC-8000 (Linux kernel 2.6 based) 

 Hardware requirement  

1) I-8212W/I-8213W/I-8212W-3GWA/I-8213W-3GWA 

    2) LinPAC-8000 
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 Establish a GPRS connection 

Modify /etc/ppp/peers/wavecom to define COM port first. Please follow the steps as 

below :  

(1) Type “ vi /etc/ppp/peers/wavecom ”  

(2) To find the “Serial device to which the GPRS phone is connected:” statement, and 

add device name of COM port.  

Modify “/etc/ppp/peers/wavecom” 

…… 

…… 

# Serial device to which the GPRS phone is connected: 

# /dev/ttyS0 for serial port (COM1 in Windows), 

# /dev/ircomm0 for IrDA, 

# /dev/ttyUB0 for Bluetooth (Bluez with rfcomm running) and 

# /dev/ttyUSB0  #for USB 

/dev/ttyS34    # serial port one 

# /dev/ttyS0     # serial port one 

# /dev/ttyS1     # serial port two 

…… 

…… 
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 I-8212W/ I-8212W-3GWA 

 

 

 

 

 I-8213W/ I-8213W-3GWA 

 

 

 

(3) Type “ :wq “ to save and quit the script. 

The default GPRS baudrate is “ 115200 ” in the LinPAC, so if users finish the setting 

of gprs modem and connect the gprs modem to the COM port of LinPAC-8000, just type in 

“ pppd call wavecom ” and then LinPAC-8000 will be connected to the internet 

automatically. Remember that the network interface card of LinPAC should stop first, just 

type in “ ifdown eth0 ” to stop it. If users type in “ ifconfig ” will see the “ ppp0 ” option.  
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Chapter 7 Quick test GPS (I-8213W /I-8213W-3GWA only) 

7.1 XP-8000 (Windows Embedded Standard 2009) 

1. Copy the tested software (Send232.exe) to your XP-8000 from the CD 

Path: CD:\ gprs_gsm_modem\I-8212W_I-8213W\Software\XP-8000\GPSTest 

 

2. Execute the tested software and select your port number of on your XP-8000, then you 

will get GPS data. 

Note: The default setting of GPS module is as follows. 

Parameters Default value 

Baud rate 9600 bps 

Parity None 

Date bit 8 

Stop bit 1 
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7.2 WinPAC-8000 (WinCE 5.0 Based) 

1. Copy the tested software (SendToCOM.exe) to your WinPAC-8000 from the CD 

Path: CD:\ gprs_gsm_modem\I-8212W_I-8213W\Software\WP-8000\GPSTest 

 

2. Execute the tested software and select your port number of on your WinPAC-8000, then 

you will get GPS data. 

Note: The default setting of GPS module is as follows. 

Parameters Default value 

Baud rate 9600 bps 

Parity None 

Date bit 8 

Stop bit 1 
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7.3 iPAC-8000 (miniOS7 Based) 

1. Download the tested software (GPS.exe) to your iPAC-8000 from the CD 

Path: CD:\ gprs_gsm_modem\I-8212W_I-8213W\Software\iPAC-8000\GPSTest 

 

2. Execute the tested software and type your port number of on your iPAC-8000, then you 

will get GPS data. 

Note: The default setting of GPS module is as follows. 

Parameters Default value 

Baud rate 9600 bps 

Parity None 

Date bit 8 

Stop bit 1 
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7.4 LinPAC-8000 (Linux kernel 2.6 based) 

Type “cat /dev/ttySn”. The ttySn represents the GPS port number of the I-8213W 

Note: The default setting of GPS module is as follows. 

Parameters Default value 

Baud rate 9600 bps 

Parity None 

Date bit 8 

Stop bit 1 
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Revised Note: 

 

Version By Date Description 

1.00 Yide 2011/03/10 Release 

1.01 Malo 2011/08/15 Add 3G module 

1.02 Malo 2011/12/28 Modify title name 

    

 


